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1. Introduction 

XTM Connect - Salesforce Commerce Cloud is an auxiliary application for both XTM Cloud and XTM 
Suite. It connects directly to Salesforce to automate the process of sending Salesforce CMS content to 
XTM and creating translation projects. Then, once the project workflow is complete, it uploads the 
translated files back to the Salesforce instance where they can follow their standard approval process. 
XTM Connect - Salesforce reduces the number of manual tasks and thereby decreases costs, 
turnaround times, and human errors. Also, the connector allows for a full in-context quality control 
before the final delivery.  

 
Use of the application is provided under a separate software license and is not included in the standard 
XTM license or subscription agreement. The installation is very simple and can be conducted by 
customers. 
 
Contact the XTM Sales Team at sales@xtm-intl.com to learn more about XTM Connect - Salesforce 
Commerce Cloud and request a quote. When you have purchased XTM Connect - Salesforce 
Commerce Cloud, XTM International will enable the API connection for you.  
 
 

2. Overview of XTM Connect - Salesforce Commerce Cloud 

Once XTM Connect - Salesforce Commerce Cloud is configured to connect with XTM, it acts as an 
intermediary application that creates projects in XTM. The content for translation is selected using the 
Salesforce user interface. Translation projects are created in XTM Cloud or XTM Suite using one of the 
predefined templates. When translation is finished, XTM sends the target files back to XTM Connect - 
Salesforce where they can be automatically published or further processed. 
 
 

 
XTM Connect - Salesforce – workflow diagram  

mailto:sales@xtm-intl.com
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3. Information for developers  

General information 

 
The XTM cartridge, which is a series of folders used for packaging and deploying code, has been 
developed and tested against Salesforce Commerce Cloud Digital 19.6 Compatibility mode 18.10 and 
Open Commerce API version 19.5. 
 
The XTM cartridge provides full support for the full XTM solution. To make use of the connector, the 
XTM team needs to configure ITS rules files which are used by XTM during file analysis. Please contact 
the XTM Support Team at support@xtm-intl.com for assistance with this. The XTM cartridge 
automatically handles all communication required between your storefront and XTM. 
 

Setting up  

 
To get started, you need to set up your environment first by uploading and registering the XTM 
cartridge.  

Uploading the XTM cartridge via Demandware Studio in Eclipse 
 
To upload the XTM cartridge: 
 
1. Download Open Demandware Studio from here: 

https://chrome.google.com/webstore/detail/demandware-with-
ease/ffhabonelknmejmdnekedmijlhebpcio?hl=en 

2. Open Demandware Studio. 
3. Click File -> Import -> General -> Existing Files into Workspace. 
4. Browse to the cartridges/directory. Select int_xtm and bm_xtm cartridges. 
5. Click Finish. 
6. Click OK, when prompted to link the cartridge to the sandbox. 

Registering the XTM cartridge 
 
The XTM cartridge is registered through Business Manager by adding the cartridge name to a list of 
cartridges: 

1. Go to Business Manager: Administration -> Sites -> Manage Sites -> Business manager site. 
This must be done for each site under Site menu. 
2. Click the Settings tab. 
3. In the Cartridges field, add :int_xtm to the end of the list. 
4. Click Apply to save the changes. 

 
Business Manager site – view 

mailto:support@xtm-intl.com
https://chrome.google.com/webstore/detail/demandware-with-ease/ffhabonelknmejmdnekedmijlhebpcio?hl=en
https://chrome.google.com/webstore/detail/demandware-with-ease/ffhabonelknmejmdnekedmijlhebpcio?hl=en
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Importing Custom Site Preferences and Custom Object Definitions into Business Manager 
 
To import custom site preferences:  

1. Log in to the Business Manager. 
2. Go to Administration -> Site Development -> Import & Export. 
3. Click Upload. 
4. Browse for the sites/site_template/meta/object-definitions.xml file contained in the metadata 
folder. 
5. Click Upload. 
6. Click the << Back button at the bottom of the page. 
7. Click Import in the Meta Data section. 
8. Select the object-definitions.xml file. 
9. Click Next -> Refresh -> Import. 

 

 
Importing custom preferences 

 
 

 
Uploading files - view 

Importing Job and Service Definitions into Business Manager 
 
To import jobs and service definitions (i.e. xml-based form properties and data validation stored in a 
cartridge): 

1. Log in to the Business Manager. 
2. Go to Administration -> Operations -> Import & Export. 
3. Click Upload. 
4. Browse for the sites/site_template/services.xml file contained in the metadata folder. 
5. Click Upload. 
6. Click the << Back button at the bottom of the page. 
7. Click Import in the Services section. 
8. Select the services.xml file. 
9. Click Next -> Refresh -> Import. 
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Importing job and service definitions 

Importing Jobs 
 
To import jobs: 

1. Log in to the Business Manager. 
2. Go to Administration -> Operations -> Import & Export. 
3. Click Upload. 
4. Browse for the sites/site_template/xtm_jobs.xml file contained in the metadata folder. 
5. Click Upload. 
6. Click the << Back button at the bottom of the page. 
7. Click Import in the Jobs section. 
8. Select the xtm_jobs.xml file. 
9. Click Next -> Refresh -> Import. 
10. Change scope of the job steps to the respective sites where you want them to run. 

Configuring XTM cartridge permissions for the Business Manager 
 
To set up XTM cartridge permissions: 

1. Go to Administration -> Organization -> Roles and Permissions -> Select the role(s) for which 
you want cartridge to be shown. 
2. Select Business Manager Modules tab. 
3. Click Select Context and choose all sites. 
4. Find XTM Translations module and select all modules. 

Configuring OCAPI resource permissions 

To configure the RESTful Open Commerce API resource permissions: 

1. Go to Administration -> Open Commerce API Settings. 
2. Select Type -> Data and Context -> Global. Add the configuration from folder 
documentation/ocapiDataGLobalConfig.json. 
3. Change the client ID in the configuration json with the one generated from your 
account.demandware.com portal. 
4. Click Save. 
5. Go to Administration -> Open Commerce API Settings. 
6. Select Type -> Shop and Context Site Where Plugin is setup.  
7. Add the configuration from the file documentation/ OcapiShopSiteSpecificConfig.json. 



 
XTM Connect - Salesforce Commerce Cloud 

 

Page 8 

 
 

8. Change the client ID in the configuration json with the one generated from your 
account.demandware.com portal.  

Note: For sandboxes you can use standard SFCC user ID: aaaaaaa… 

9. Click Save. 

Configuring Services 
 
To set up Services: 

1. Go to Administration -> Operations -> Services.  
2. Click the Credentials tab. 
3. Select xtm.ocapi.token.get.credentials.test. 
4. Set the credentials generated for the current merchant in account.demandware.com.  

Note: For sandboxes you can use standard SFCC user id: aaaaaaa… 

Credentials tab 

Configuring Custom Preferences using the Business Manager 
 
To set up custom preferences: 

1. Log in to the Business Manager. 
2. Select the site from the menu at the top of the page, where you want to set up the XTM Module. 
3. Click Merchant Tools -> Site Preferences -> Custom Preferences -> xtmConfig. 
4. Fill in the Site Preferences as directed. Parameter values will be provided here. If you do not 
already have them, XTM Client ID, XTM User Id, and XTM Auth Password will be provided by XTM 
International. 
5. Click Save. 

 
Custom site preferences  
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4. Setting up XTM environment 

To set up your XTM credentials, follow the instructions below: 

1. Go to Merchant Tools -> Site Preferences -> Custom Preference to open the Custom Site 
Preference Groups, where you can create custom preferences for sites.  
2. Provide your XTM credentials for the XTM Client ID, XTM User Id, and XTM Auth Password 
fields. 
3. XTM Source Language: Set up locales you will be sending to XTM system as a source 
language. You can set up multiple values. The expected format is the code of the language, i.e. 
en_US, en_GB. 
4. XTM Customer IDs: Set up XTM-specific customer IDs. For demonstration purposes, the 
mapping is customerId|customer name, i.e. 23|TT Soft Customer ID. 
5. XTM Product Attributes: For each exportable object: Product, Categories, Content Assets, 
Content Slots, Promotions, Shipping Methods, Payment Methods, exportable attributes for 
translation must be set. An ID is a mandatory attribute, so it should always be set for each exportable 
object. 

For system objects use the attribute name defined in System Object Definition for the respective 
group, i.e. ID, name, shortDescription, longDescription. 
For custom attributes use the prefix: custom. + attribute name, i.e. custom.size. 

6. XTM Localizable Product Attributes: For each exportable object: Product, Categories, Content 
Assets, Content Slots, Promotions, Shipping methods, Payment methods, localizable attributes must 
be defined. Any attribute defined in step 4 that is set as localizable in the System Object preferences 
must be listed here, following the same patterns as in step 4. For instance, if a name is defined as a 
localizable attribute, it should be placed on the respective list for the translated object. 
7. Mandatory Attributes for each exportable object: 

- Product: ID 

- Category: ID 

- Content Asset: ID 

- Content Slot: configuration_id, slot_content.type, slot_content.body, context, context_id 

- Promotion: ID 

- Payment Method: ID 

- Shipping method: ID 

8. XTM Attribute Mapping is used for mapping between the System Object type attribute definitions 
and the OCAPI update request document for specific exportable object. For example, in a product 
system object description it is defined as shortDescription and in the OCAPI update request 
document the attribute is defined as long_description. 
9. Possible mapping objects that can be defined are: 

a. Product 

b. Category 

c. ContentAsset 

d. ContentSlot 

e. Promotion 

f. ShippingMethod 

g. PaymentMethod 

 
 
 



 
XTM Connect - Salesforce Commerce Cloud 

 

Page 10 

 
 

Example config:  
{ 
 "Product": { 
  "longDescription": "long_description", 
  "shortDescription": "short_description" 
 }, 
 "Category": { 
  "displayName": "name" 
 }, 
    "ShippingMethod": { 
        "displayName": "display-name" 
    } 
} 
 
 

You can create custom preferences for sites, and then view and edit them both locally and across 
multiple sites. Custom preferences let site developers make properties of the system modules 
configurable in the Business Manager. 
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XTM Configuration site 
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Jobs  

Jobs automate routine tasks or long-running processes. Jobs can use out-of-the-box system steps, or 
a developer can create custom job steps. You can run jobs manually (see here) as needed or 
schedule them to run at a specific time or on a recurring basis (see here). 

Configuring jobs 

To configure a job: 

1. Go to Merchant Tools -> XTM Translations -> Job Configurations. 
2. Click the Add New button to open a pop-up window. 
3. In the pop-up window specify: 

Config ID: Provide a descriptive name for the configuration. 
Select Source and Target languages for the translation. 
XTM template: Select predefined XTM templates, if available. 
XTM customer ID: Select XTM customer ID defined in site preferences. 
Categories: Add categories for the export. If you want all categories to be exported use a root name. 
A job will export products from the sub-categories as well, so only top-level categories can be set up. 

Enabled: this will enable the configuration for export. Disabled configurations won’t be picked. 
Include Variations: this option enables variation products assigned to master or variation group 
products to be included in the export as well.  
Enable Auto-translate: this will pick only products with auto translate flag set to Yes 

4. Click Submit to complete the process. 
5. You can modify any of the configured jobs any time by clicking the pen icon under Actions.  

Only enabled configurations will be picked by the job responsible for the delta export. 

For each job configuration, the following actions are available: 

 

 

Enable/disable rule 

 

Edit configurations 

 

Delete configurations 
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Job configurations – pop-up window 

 

New job configuration added – Jobs configurations 
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5. XTM Connect user interface in Salesforce 

XTM controls are integrated in the Salesforce interface. You can find them in the top navigation bar.  

 

 
XTM Salesforce top navigation bar 

 
To enter XTM controls: 

1. Go to your preconfigured tab and click to open a drop-down menu. 
2. Choose the relevant site (for demonstration purposes, we named ours: RefArch). 
3. Go to Merchant Tools to open a window with items.  
4. Find XTM Translations and choose Translations. 

 

 
Merchant Tools menu items 

 
 

Sending content for translation manually 

Selecting content 

To send your content to XTM TMS for translation first you need to specify what content items to send. 
The XTM cartridge will export the following objects for translation: 
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• Products – automated and manual 

• Categories  

• Content Assets 

• Content Slots 

• Promotions 

• Shipping Methods 

• Payment Methods – manual only 

Only a configurable set of attributes (described here) will be sent for translation. 

Finding content items 

Under the Products tab, you can search your content items by words or IDs.  

To find content by specific words: 

1. Choose the content you wish to translate by typing one word in the search field. 
2. All the content containing such word will be displayed. 
3. Select the content by ticking the boxes. 
4. Click the Translate Selected button to open a pop-up window. The number on the Translate 
Selected button indicates the number of content items you have selected.  

 
 

 
Selecting content for translation – by words 

 
 

To find content by ID: 

1. Choose the content you wish to translate by typing a single content ID in the search field. 
2. The content is displayed with its ID. 
3. Tick the box to add a content item to selected translations. 
4. You may repeat the steps 1-3 to add more content items for translation.  
5. Click Translate Selected. The number on the Translate Selected button indicates the number of 
content items you have selected.  
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Selecting content for translation – by IDs 

Sending content 

Once you’ve selected the content you want to send to XTM TMS for translation you need to specify 
project details.  

To specify project details: 

1. Click the Translate Selected button to open a pop-up window. 
2. An Add to Queue pop-up window opens. 
3. Type a descriptive name for your project, choose the source language and target language(s) for 
the translation, select pre-defined XTM templates as well as your Customer ID.  
4. Click Submit to send the job to XTM. 

 
Submitting content items for translation 

 
 

 

The selected objects are sent for translation. Once sent, a message pops up in the bottom right 
corner confirming that you’ve successfully completed the process, or notifying you that some 
information is missing and the project could not be exported for translation.  
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XTM system messages 

 
Once the translation is ready, the project will be automatically imported from XTM TMS to Salesforce 
Commerce Cloud. 

Note: It is possible to check if your jobs were properly sent for translation by SFCC. Add your client 
URL to the link: /on/demandware.servlet/webdav/Sites/Impex/src/xtm/archive/import. For example, for 
XTM demonstration purposes, the link is: https://xtminternational01-tech-prtnr-na03-
dw.demandware.net/on/demandware.servlet/webdav/Sites/Impex/src/xtm/archive/import. 

Checking translation status 

The XTM Salesforce connector will let you manage XTM projects from the Salesforce Business 
Manager. Projects can be deleted and reimported after the initial import. 

To check your project status of translation: 

1. Go to Merchant Tools -> XTM Translations. 
2. Choose Project Status. 
3. A list of all projects displays. To narrow down the view to selected projects, type project ID or any 
part of the project name.  

 
List of project statuses – narrowed down by name 

 
 
If a project status is Finished, you can download it by clicking the circle arrow icon. The option to 
import items is blocked when a project status is Active. To remove a project, click the red bin icon.  

Re-importing translation from XTM manually 

To download the translated project (re-import it to Salesforce Commerce Cloud): 

1. Go to Merchant Tools -> XTM Translations module -> Project Status. 
2. Find your project using the search field. 
3. Click on the circle arrow icon (Reimport) by the project. 

https://xtminternational01-tech-prtnr-na03-dw.demandware.net/on/demandware.servlet/webdav/Sites/Impex/src/xtm/archive/import
https://xtminternational01-tech-prtnr-na03-dw.demandware.net/on/demandware.servlet/webdav/Sites/Impex/src/xtm/archive/import
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4. The translated files will be downloaded automatically. 

 

 
Job reimported successfully 

Finding translated content 

If you want to find any of the translated content items: 

1. Go to the Merchant Tools -> Products and Catalogs -> Products to be taken to a search window.  

 

 
Products search engine 

 

Here, you can use three search options: Simple, Advanced or By ID: 

 
a) Simple search: type any part of the product name or product ID  
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Simple search option by product ID  

 
 

 
Simple search option by product name  

 
 

b) Advanced search: search by product name and ID as well as specify other attributes 
 

 
Advanced search option 

 
 

c) By ID: search more than one project using several IDs 
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Selected project products 

 

2. Click product ID or name link to open the Product Page General tab. Then select the translation 
target language. 

 
Product Page General 
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Translated content view 

Importing in Salesforce Commerce Cloud  

In this area, you can check if the job responsible for importing in Salesforce Commerce Cloud is 
working properly. You can also view the job status, end time and duration as well as download a log 
file.  

1. Go to the Administration tab -> Operations -> Jobs.  
2. Click the XTM-DownloadAndImportFiles link and check Schedule and History. 

 
Operations -> Jobs 

 

 
History of jobs under Schedule and History tab 
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Sending translation jobs automatically 

 
Our connector enables automation when it comes to sending products for translation in bulk and at 
certain time intervals. With the XTM cartridge, products for translation will be automatically exported. 
All products modified after a certain date will be sent automatically for translation. Such option comes 
in handy when a customer has another system which uses Salesforce Commerce Cloud API changes 
any product-related data. However, first, the following conditions need to be complied with:  

a) XTM Last Modified date is later than the last date/time of launching an XTMExportProduct job 
successfully. 

b) Other, additional criteria are met, as defined in XTM -> Job Configurations. 
 

Scheduling automatic sending of jobs 

 
To define when content items are to be sent for translation: 

1. Go to Operations -> Jobs.  
2. Go to XTMExportProducts -> Schedule and History. 
3. Tick the box by Enabled to run jobs on schedule. 
4. Set schedule parameters such as trigger, time period, frequency, etc.  

Instead of selecting manually the product you want to send for translation, pre-set parameters will 
send the new or updated content automatically to XTM at specified times. 

It is possible to define specific rules for automatic sending of products for translation – more details 
here. 

 

 
Scheduling times for sending translation 


