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1. XTM Connect - AEM Introduction 

This manual describes how to install, configure and use the modules required for Adobe Experience 
Manager to integrate with XTM. 

General information  

• AEM has a synchronous line per line translation mode, this is generally referred to as Translation 
API 1.0, and is always an MT type of translation. 

• AEM has asynchronous per document translation mode, referred to as Translation API 2.0, and 
can be either human- or machine-translation. 

2. XTM Connect - AEM Prerequisites 

Prerequisites 

• Access to an AEM 6.2 installation 

• Acces to an XTM server 

3. Installing the XTM Connect - AEM 

To install the XTM Connect for AEM as a translation provider, the CrossLang-XTM connector package 
must be downloaded from Package Share. After installing the package, you can create a cloud 
configuration as is described in Configuring the AEM-XTM Connector below. 

Working with Packages: 

For more information on how to work with packages, please refer to 
http://docs.adobe.com/docs/en/aem/6-2/administer/content/package-manager.html. 

Summary of steps: 

• Obtain the CrossLang-XTM connector package 

• Upload the package 

• Install the package 

Obtaining the CrossLang-XTM Package from Adobe Package Share 

To obtain the CrossLang-XTM package, proceed as follows: 

http://docs.adobe.com/docs/en/aem/6-2/administer/content/package-manager.html
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1. Open a browser and navigate to https://www.adobeaemcloud.com/content/packageshare.html: 

 

 

2. Find the CrossLang-XTM for Adobe Experience Manager package: 
 

 

3. Click on the CrossLang-XTM-Translation-Connector tile to see the package's details and 
download the package using the download link provided on the Assets tab: 

https://www.adobeaemcloud.com/content/packageshare.html
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Notes:  

• AEM 6.2 requires version 1.2.2 of the XTM connect. 

• The connector package can also be downloaded directly from within AEM by accessing Package 
Share via the CRX Package Manager (http://localhost/crx/packageshare/index.html). 

Uploading the CrossLang-XTM Package 

To upload the CrossLang-XTM package, proceed as follows: 
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1. Log in to your AEM instance and navigate to Tools › Deployment › Packages: 

 

 

2. Click Upload Package, then Browse, and find the package that you downloaded from Adobe 
Package Share: 
 

 

3. Click OK to upload the package. 
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Note: when accessing Package Share from within AEM, the package can be downloaded directly from 
the Package Share interface by clicking the Download link. 

Installing the CrossLang-XTM Package 

To install the CrossLang-XTM package, proceed as follows: 

1. Click Install to install the package: 
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2. Click Install again to start the installation: 
 

 

3. The package is now installed and ready for use: 
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4. Configuring the XTM Connect - AEM 

This section describes the minimal configuration that is needed to make the integration work. 

Creating a CrossLang-XTM Cloud Service Configuration 

After having uploaded the CrossLang-XTM-Translation-Connector package, a cloud service 
configuration needs to be created. 

To create a CrossLang-XTM configuration, proceed as follows: 

1. Navigate to Tools › Deployment › Cloud Services. 
2. In the Third Party Services section, scroll to the CrossLang-XTM service and click Configure 

now if this is the first configuration you are creating for the service or Show Configurations and 
then [+] if you want to add an additional configuration to existing configurations. 

3. Specify the following information: 
 

 
Title: This is the name of the configuration as it will be shown in the AEM interface. Can be any 
value.  
Name: (Optional) This is the internal name that AEM uses. The name cannot contain spaces. 

4. Click Create. 
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5. Specify the basic CrossLang-XTM configuration parameters: 
 

 

Web Service URI: This is the location at which the XTM web service can be reached. E.g. 
"http://wstest2.xtm-intl.com/project-manager-gui/services/v2/XTMProjectManagerMTOMWebService". 
Company: This is the Company as specified in XTM. E.g. "Test Company". 
User Id: This is the unique user Id of the XTM user that will be used for the interaction with XTM. E.g. 
"1234". 
Password: This is the password of the XTM user that will be used for the interaction with XTM. E.g. 
"p4SSw0rd". 

6. Click Verify XTM connection. 
1. If the connection can successfully be established, the Customer drop-down will be 

populated with the Customers in XTM that the specified user has access to. 
2. If the connection cannot be established, review and correct the specified values and try 

again until the connection passes.  
7. Select the XTM Customer under which projects created by AEM will be created in XTM. Once a 

Customer has been selected, the Project Template drop-down will be populated with the 
templates in XTM for the selected Customer. 

8. Select the XTM Project Template to be used for the projects created by AEM in XTM. 

Note: Multiple CrossLang-XTM configurations can be created to provide for different needs. A typical 
use case, for instance, would be different web site sections with different translation process 
requirements. Some content may not require review whereas other content might. In that case, the 
user may want to create two CrossLang-XTM configurations: one with a Project Template selected 
that includes a Review and Correct step, and another that does not include those steps. 

http://wstest2.xtm-intl.com/project-manager-gui/services/v2/XTMProjectManagerMTOMWebService
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Creating a Translation Integration Cloud Service Configuration 

After having created a CrossLang-XTM cloud service configuration, a Translation Integration cloud 
service configuration needs to be created. 

To create a Translation Integration configuration, proceed as follows: 

1. Navigate to Tools › Deployment › Cloud Services. 
2. In the Adobe Marketing Cloud section, scroll to the Translation Integration service and 

click Configure now if this is the first configuration you are creating for the service or Show 
Configurations and then [+] if you want to add an additional configuration to existing 
configurations. 

Specify the following information: 
 

 
Parent Configuration: Keep suggested value. 
Title: This is the name of the configuration as it will be shown in the AEM interface. Can be any value.  
Name: (Optional) This is the internal name that AEM uses. The name cannot contain spaces 

3. Click Create. 

Specify the Translation Integration Configuration parameters: 
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Translation Workflow: select Human Translation. 
Translation Provider: select XTM Translation Service. 
Translate Component Strings: controls whether or not i18n dictionaries used in the components of 
the page will be part of the translation job. 
Translate Tags: controls whether or not associated tags will be part of the translation job. 
Translate page assets: controls which translation workflow will be used for translating page assets. 
Auto-execute Translation: controls whether or not newly created translation jobs are started 
automatically. 
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Translation Workflow: select Human Translation. 
Translation Provider: select XTM Translation Service. 
Translate Assets: controls whether or not referenced binary assets will be part of the translation job. 
Translate Metadata: controls whether or not associated metadata will be part of the translation job. 
Translate Tags: controls whether or not associated tags will be part of the translation job. 
Auto-execute Translation: controls whether or not newly created translation jobs are started 
automatically. 

4. Click OK. 

 

Configuring the Translation Integration Framework: 

For more information on the configuration options, please refer to https://helpx.adobe.com/experience-
manager/6-2/sites/administering/using/tc-tic.html. 

Applying the Cloud Service Configuration 

Once the required cloud service configurations have been created, they need to be applied at the 
desired level of your Site hierarchy. 

To apply a cloud service configuration, proceed as follows: 

https://helpx.adobe.com/experience-manager/6-2/sites/administering/using/tc-tic.html
https://helpx.adobe.com/experience-manager/6-2/sites/administering/using/tc-tic.html
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1. Navigate to Sites, then to the node in the site hierarchy at which level you want to apply the 

configuration. 

 

 

2. Open the References tab (icon on top of the site list) and select the node to which you want to 
apply the configuration. For example, the top level of the site: 
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3. Click View Properties, then CLOUD SERVICES: 
 

 

4. Select the Translation Integration cloud service you created earlier from the Configuration 
Reference drop-down: 
 

 
  

5. Click the + sign next to Add Configuration under Cloud Service Configurations and 
select CrossLang XTM from the drop-down: 



XTM Connect - AEM 

 

Page 17 

 

 

6. Select the desired CrossLang XTM configuration from the CrossLang XTM Configuration 
Reference drop-down: 
 

  

7. Click Save to confirm the configuration changes made. 
8. Click Close to close the Properties screen. 

AEM is now ready to submit content to XTM. 
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5. Using the XTM Connect for AEM 

This section describes the basic steps for translating AEM content with XTM. 

Summary of steps: 

• Create a translation project and a translation job 

• (Optional) Scope the translation job 

• Start the translation job 

• Complete the translation job 

Creating a Translation Project and Translation Job 

To create a translation project, proceed as follows: 

1. Navigate to Sites, then to the node in the source language's site hierarchy that you wish to create 
a translation project for: 
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2. Open References and expand the Language Copies section: 
 

 

3. Click Create & Translate and select the language copies you wish to add (Check Select all sub-
pages if you wish to include all child pages of the selected node in the translation project). From 
the Project drop-down, select whether you want to create a new project or create a new 
translation job for the selected nodes in an existing project: 
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4. Specify a name for the translation project in the Title field and click Create to create the project: 
 

 

Notes: 

• If you selected the Create a new translation project option, AEM will create a translation project 
with the cloud configuration applied to the selected node and will create a translation job that 
holds the selected pages (and referenced assets if so configured). 

• If you selected the Add to existing translation project option, AEM will create a translation job that 
holds the selected pages (and referenced assets if so configured) within the selected project. 

Scoping a Translation Job 

Upon creating a translation project, AEM will automatically create a translation job under it that holds 
the site pages that were selected for translation.  

To scope the translation job, proceed as follows: 

1. Navigate to Projects > [project_folder] > [name_of_project_just_created]: 
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2. Select Request Scope from the drop-down in the Translation Job tile: 
 

 

3. Click on Translation Job to see the Translation Job's contents and check on scoping request 
progress: 
 

 
Once scoping is complete, the Translation Job status changes to Scope Completed. 

Select Show Scope from the drop-down in the Translation Job tile to see scoping information:  
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Scoping information is shown:  
 

 
 
If you click Details, a one-time link, that directs you to XTM, is generated: 
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When you click Allow, the metrics for the XTM project are opened in another tab. Note that this is a 
one-time link that works only once. To save the metrics displayed for future reference, choose a value 
from the Save all as drop-down at the top right of the Metrics page. 
 

 

Starting a Translation Job  

To start a translation job, proceed as follows: 

1. Navigate to Projects > [project_folder] > [name_of_project_just_created]:  
 

 

Select Start from the drop-down in the Translation Job tile: 
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The translation workflow is now initiated on the side of XTM.  

2. Click on Translation Job to see the Translation Job's contents and check on translation progress:  
 

 

Completing a Translation Job 

A translation job that has been started will move through the workflow steps of the workflow that was 
configured as part of the XTM Project Template that was selected for the XTM-CrossLang cloud 
configuration. 
AEM will check the status of submitted pages and assets at a configured interval. 

When a page or asset is found to have all workflow steps completed, AEM will automatically retrieve it 
and show it with status Ready for review in the translation job: 
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Translated pages and assets can now be reviewed in AEM. 

Once all pages have been reviewed, the Translation Job can be completed as follows: 

1. Navigate to Projects > [project_folder] > [name_of_project_just_created]:  
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2. Click on Translation Job to open the Translation job: 
 

  

3. Click on one of the pages in the list or select multiple/all pages from the list. At the top, two 
buttons become visible (Accept Translation and Reject Translation): 
 

 

4. Click Accept Translation, if you want to approve the translation. A pop-up window opens. 
Click Accept. 
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5. After refreshing, you will see that the status of the selected page(s) has changed to Approved. 
 

 

Click Reject Translation, if you don't approve the translation of the page. A pop-up window opens. You 
can optionally add a comment. Click Reject. 
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Note: Any comments provided when rejecting pages will be not visible in XTM. 

6. The status of the page(s) will show Rejected and will shortly after change to Translation in 
Progress. The final step in the translation workflow in XTM has been reactived to allow for making 
corrections. 
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6. Context Preview 

Note: Context preview requires AEM 6.2 SP1 CFP14 or higher and XTM Connect version 1.2.2. 

Visual Editor 

Context preview will send additional information such as graphics and stylesheets across to XTM in 
order to allow XTM to open up the page that is being translated in its Visual Editor. Opening a page in 
the Visual Editor will show the page almost exactly like it looks in AEM. 

In AEM: 

 

In XTM's Visual Editor: 
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The XTM user can view and edit the page being translated in the Visual Editor. Any changes made in 
the Visual Editor will be reflected in XTM's Translation Memory and in the translated copy of the page 
that will be retrieved by AEM once the translation workflow has been completed. 

Configuration 

To enable context preview, a page exporter configuration needs to be created for your site in AEM. 

Creating a Page Exporter Configuration: 

For information on how to create a page exporter configuration, please refer to 
https://helpx.adobe.com/experience-manager/6-2/sites/administering/using/page-exporter.html. 

Once a page exporter configuration for your site exists, the XTM connect - AEM will, for each page to 
be translated, create a zip file that contains an offline copy of the page with layout and automatically 
send that zip file to XTM along with the XML source file that will be used for translation. XTM will 
combine the information from the XML file and the zip file to show the page in the Visual Editor. 

The Visual Editor is enabled in XTM by default for file formats for which it is supported. No 
configuration is required. 

 

 

 

 

 

 

 

 

 

 

 

 

https://helpx.adobe.com/experience-manager/6-2/sites/administering/using/page-exporter.html
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7. Additional Translation Integration Framework Configuration 
Options 

AEM's Translation Integration Framework has 3 OSGi configurations in AEM 6.2. These configurations 
will influence the behavior of the AEM Translation Integration Framework and can be found 
under: http://localhost:4502/system/console/configMgr. 

Translation Integration Default Config 

Translation Integration default connector – The connector name of the system default implementation. 
(defaultConnectorName) 

Translation Integration default category – The system configured default category for the Translation 
Integration framework. This value should correspond to a node name found within 
/libs/granite/translation/resources/categories (defaultCategory) 

Translation Integration Framework Mappings 

Language List location – The repository path where the list of supported languages is stored. 
(com.adobe.granite.translation.helper.languages) 

Content Category List location – The repository path where the list of supported content categories is 
stored. (com.adobe.granite.translation.helper.categories) 

The XTM connect for AEM defines its own language mapping list. This is to ensure that all the AEM 
language codes map to a valid XTM language code. If a customer has changed the language codes 
used in AEM, then he must make sure to update the mappings. Failing to do so will result in a 
'Language not supported' error. 

Translation Platform Configuration 

Scheduler Cron – Please specify cron format for changing the scheduling 
(syncTranslationState.schedulingFormat) 

Sync lock timeout – Please specify value in minutes after which translation sync lock will time out. 
(syncTranslationState.lockTimeoutInMinutes) 

Export Format – Please specify the format for exporting translation jobs (export.format) 

The AEM Translation Integration Framework can deliver the translation objects in either XML or XLIFF 
format. Default is XML. XLIFF support can be enabled by changing the value of the Export Format 
option of the Translation Platform Configuration OSGi configuration. To enable the use of XLIFF 
(variant 1.2 or 2.0), the user must also install package okapi-xliff-service-pkg from Package Share. 

http://localhost:4502/system/console/configMgr

